How to use Potato MU Client

  • Coder

    @skew said in How to use Potato MU Client:

    @Thenomain When I played on that SW MU, it would often strip out carriage returns from poses, on and off, sort of at random. Recently, some update to Evennia also had Arx eating up carriage returns and not adding posebreak carriage returns. They got it resolved, I think, but it was happening.

    The Evennia issue was actually one where it added extra lines for some people; the only way to eat all the extra newlines was to suppress empty lines on the client side, thus causing posebreaks and empty lines that should be there to vanish as well. It was fairly quickly fixed.

  • Pitcrew

    @Thenomain @Rook @skew

    I've noticed it across multiple MU*, and it's just what I type, it's also what the game outputs. So, for example, login screens that're formatted with ANSI art look all messed up, because the %Rs aren't registering on my client.

    I've also discovered that if I clone the site in Potato and connect to the duplicate, the issue goes away. I've gone through every single option to make sure they're identical between the clone and the original, and they are. I feel like I have carbon monoxide poison or something.

  • Coder


    That sounds like a repeatable sitation that you can send to the Potato development team as a bug. If they have a chat room, that'd be a good place to start too.

  • @rebekahse It sounds like you've been really thorough so it's unlikely, but maybe double check both the configure world settings and the configure program settings? Since it can have settings in two place, I guess it's possible one of the two could be overlooked and it could be something really random.

  • Coder

    Worst case scenario, carefully copy your World settings to the new World instance, along with characters and so on... but leave alone anything that could be an input/output modification or setting (screen wrap size, fonts, etc). On the new World instance, SLOWLY introduce those other settings back, one at a time, testing after every change until you find the culprit.

  • I'm going to have to take some time to dig into this further. I've been using SimpleMU for years, but the functionality of Potato seems to be pretty good and the dual text windows can be useful.

    Where I got hung up in my initial poking at the program was dealing with events I want to set up. I'm accustomed to having pages colored yellow to help me separate them from everything else, but in SimpleMU I can also have my character's name show up as green. I've found this makes it easier to pick out when a lot is going on and I need to focus on something.

    My problem so far is I haven't been able to get Potato's interface to accept both things at the same time. I can have pages show up in yellow but the name is caught with it, or I can have the name in green but the page itself doesn't change color. None of the combinations of things I tried setting would work for that. I'm sure there's a way, but I haven't figured it out yet.

  • Coder

    @Wolfs In your events, make sure you check the box marked "Continue". Basically, if unchecked, it processes that one event and stops. Ie, it gets to coloring your name, or the page itself, and stops. If you click continue, it will process that event then move on to the next one.

  • @skew Thanks. I'll have to test that out and see if it solves the issue I had. I'm not very good with the format of the syntax that requires compared to how SimpleMU handles it.

  • Coder

    To add on to @skew's excellent advice, note that you can order your Events. Processing starts at the top and goes down, so if you want your name highlight event to be always happening, make sure you have the 'Continue' checked and your name-highlight rule at the bottom of the list.

  • Pitcrew

    So, I'm having a problem with Potato where, when it tries to save or change a file, it has apparently changed all the backslashes to forward slashes.

    As a result, whenever I close Potato or try to add a new world, I'm getting a bunch of errors. For example, the following is an error I get when trying to close the program:

    Unable to save skin prefs to: "C:\Users\Lisse24\skins\skin.prefs": Couldn't open "C:/Users/Lisse24/skins/skin.prefs": premission denied

    Any clue on how to fix?

  • I'd start in Options > Global Events or Options > Configure Events, see if something was added in there that includes replacing backslash with forward slash?

  • Admin

    @Lisse24 Have you tried running it as administrator, since the error itself is about permissions?

  • Pitcrew

    Did both those things, to no luck.

  • Admin

    @Lisse24 Does Windoze let you edit C:\Users\Lisse24\skins\skin.prefs directly if you try to do it as admin?

  • Someone at MUSH might have a solution (

  • I'd suggest that you log on to MUS*H and talk to Mike. He's the guy that wrote it and he's usually happy to support it. He's in the UK so might on at weird times.

  • Pitcrew

    Thanks all - that will probably be my next step.

  • Coder

    @Lisse24 Also make sure you're updated to the latest version, just in case.

  • Coder

    Because someone asked, and for some reason I put it in another thread... Cross linking. In case I didn't already. Also editing to put it in the original...

    How to enable spell check in Potato:

  • Coder

    Another trick... Sometimes, ctrl+c doesn't copy text out of the text scroll. No idea why.

    Go to Options -> Configure Program Settings -> Program Settings -> Misc Settings -> Select to Copy

    alt text

    When you select text in your text scroll, it will auto-copy it, soon as you select it. Note that does get a little annoying if you copy something else, then select something, it overwrites the "copy". Likewise, if you don't unselect the text, and flick back and forth between windows, it may copy the selected text again. Still, way prefer this way to ctrl+c being unreliable.