How to use spellcheck on Potato MU Client


  • Coder

    This will walk you through enable spellcheck on the Potato MU client. This was originally posted on Fallcoast (don't recall the author) and I forgot to save it somewhere, then got a new computer, and had to figure it out again. So I'm putting it here!

    Install Instructions

    Potato uses the aspell spellchecker for accomplish this feature, so first install aspell. The windows version can be found here: http://aspell.net/win32/

    Look for "Full Installer". It should download a .exe file that you can run. You can leave all the settings as-is. Once this is complete, go back to the aspell.net page and snag the appropriate language file. That's likely English. This should download another .exe file, and if you used the default settings for the first install, you can use the default settings for this install. Just make sure it ends up in the same spot.

    Once that is installed, open up Potato. From within Potato, go to Options - > Configure program settings. In the Program Configuration window, go to Program Settings, then Misc Settings. You should see a field for "ASpell Executable". Input the location that you installed the ASpell executable. If you stuck with the defaults, it should be: C:\Program Files (x86)\Aspell\bin\aspell.exe (assuming you have a 64 bit machine, which most people do these days.)

    Once that is in, you should be done. I believe the default is command to activate spellcheck is Ctrl+S -- if it's not, you can go to Options -> Customize Keyboard Shortcuts. You can also click Edit -> Check Spelling.

    Please note that there is no "on line" spell check. It doesn't underline words you spelled wrong, but instead opens a window to check.

    Troubleshooting

    If you hit Ctrl+S and nothing happens, check to make sure you have the keyboard shortcut.

    If you definitely have the keyboard shortcut and nothing happens, it means it's not finding aspell.exe, so make sure the path you specified in the Program Configuration window is correct.

    If the window opens and you receive an error saying something like "No words found" or "no language found" or something, it means you did not install the language file. Go back to that step, download the language file, install the language file.


Log in to reply
 

Looks like your connection to MU Soapbox was lost, please wait while we try to reconnect.