Transfer of MSB tonight: 7:30 EST


  • Coder

    @arkandel said in Transfer of MSB tonight: 7:30 EST:

    @thenomain You don't see an eyeball on the usernames' right side in every post?

    Oh is that what that’s for? Moderately bad interface design, but yeah, I see it. Huh.


  • Admin

    @thenomain Weird though, that's the same plugin we were using before. I had never used it myself, mind you, but I'd have expected the interface to be the same... maybe it's a newer version thing.



  • Thank you, @Arkandel. I'm sure there's a lot of us who appreciate the return of that function.


  • Coder

    @arkandel said in Transfer of MSB tonight: 7:30 EST:

    @thenomain Weird though, that's the same plugin we were using before. I had never used it myself, mind you, but I'd have expected the interface to be the same... maybe it's a newer version thing.

    Well I’ve also never used it. I’ve tried using ignore on people in the past, but it turns out that I can’t follow the conversation when I can’t see what people are responding to. Funny that. To me it’s far easier to see what people are seeing and roll my eyes; I am kept in the know and my eyes get some valuable exercise.


  • Admin

    @surreality said in Transfer of MSB tonight: 7:30 EST:

    Thank you, @Arkandel. I'm sure there's a lot of us who appreciate the return of that function.

    Sorry about not transfering the ignore lists over. nodebb breaks if you look at it funny, so I didn't want to simply copy over the old directory to the new host.

    By the way, automated backups seem to work properly. I have on- and off-site daily data and image (avatars, etc) .bz2 archives going back 21 days, which should be enough for now. I might need to reinstall the forum if something catastrophic happens to the Linode but at least we aren't likely to have a WORA-level loss again.


  • Coder

    @arkandel said in Transfer of MSB tonight: 7:30 EST:

    By the way, automated backups seem to work properly. I have on- and off-site daily data and image (avatars, etc) .bz2 archives going back 21 days, which should be enough for now. I might need to reinstall the forum if something catastrophic happens to the Linode but at least we aren't likely to have a WORA-level loss again.

    I want to note that I have both the last Wora backup and Swofa flat-files floating around on my hard drive. It's not trivial to pull data from it, but if anyone needs and my giv-a-dam is not too low, I can look to find the information.


  • Admin

    @thenomain Migrating from an older dumpfile might be challenging by now. I had issues using the current redis flat file over the weekend when nodebb was running its upgrade scripts for it, and that was just over a relatively small versions gap. Note however that this could have been caused by memory restraints (this is running on a 2GB host) while having to load process it at the same time.

    WORA was using SMF if I remember correctly? I'd be curious to see if the current version of the platform would load the data from it at this point.


  • Admin

    I am told new user e-mail validation isn't working as expected. I'll need to look at it tonight - in the mean time I'll validate those users manually. It sounds like a sendmail issue.


  • Admin

    Forum e-mails ought to be playing ball with sendmail now. If there are any issues validating new accounts or receiving digests please let me know and I'll look into it.


  • Pitcrew

    @arkandel said in Transfer of MSB tonight: 7:30 EST:

    sendmail

    Well, geez, no wonder it wasn't working! The Clinton Administration called, they want their MTA of choice back.

    ( :) )


  • Admin

    @autumn YOU TAKE THAT BACK RIGHT NOW sendmail IS THE BEST


  • Pitcrew

    @arkandel Sure, sure. Why, when you get sendmail set up and running properly* on a 386 running Slackware -- that's as good as it gets! Crack open a Zima and toast a job well done.

    [*]: to the extent that sendmail ever runs properly, that is.



  • Postfix ftw :)



  • Is the forum being super wonky in terms of maintaining connection, or is it just me?

    I also had a notification for a chat message pop up, but no actual new messages.

    IDK.

    If you just sent me something, I didn't see it.


  • Pitcrew

    @tempest said in Transfer of MSB tonight: 7:30 EST:

    Is the forum being super wonky in terms of maintaining connection, or is it just me?

    It's not just you.


  • Admin

    @krmbm Something is wonky. I am looking into it.


  • Admin

    I think this might be under control now. I'll continue to monitor it, but the symptom seems to have been a rogue nodebb process was fired up which led to EADDRINUSE errors as the service kept dying then firing itself up again.

    I still need to look into what caused this mess. Meh, redis.


  • Coder

    @arkandel Doesn't really seem to be under control bruh.


  • Admin

    @alzie Were there issues today? I see nothing in the logs (whereas yesterday things had gotten spammy).

    By the way if anyone here is versed in redis and feels like lending a hand please drop me a line.


  • Coder

    @arkandel occasionally, I get internal errors when trying to go to unread and when trying to change pages while also writing a reply. They're very specific situations, so that's a good and bad thing for you. I assume internal error means a failure on some Ajax request somewhere and is probably not actually a server error or I'd not even get the error toast.


 

Looks like your connection to MU Soapbox was lost, please wait while we try to reconnect.