[Request] Places Desc'ing

  • Well something happened overnight between my logging out and logging back in. The room descriptions seen when joined at the places were still there, but the main room default wiped to: placedesc.none.

    Tried wiping everything twice and doing it over, but it now just puts the 'placedesc.none' in. No idea why it worked yesterday and not today, nor why it wiped.

  • Tutorialist

    If you can drop the code you're using here, we can try and diagnose it. It might be a problem with the udefault().

  • @Cobaltasaurus - I simply copy pasted in exactly what Theno had put:

    @desc here=udefault( placedesc.[places( whichplace, %!, %# )], placedesc.none )


    &placedesc.none here=%r%tTHIS IS HOW THE ROOM LOOKS WHEN NOT JOINED TO A PLACE..%r
    &placedesc.1 here=%r%tTHIS IS HOW THE ROOM LOOKS FROM PLACE 1%r
    &placedesc.2 here=%r%tTHIS IS HOW THE ROOM LOOKS FROM PLACE 2%r

    Not sure if I was meant to change anything from what Theno put, I understand nothing about code whatsoever :)

  • Because I derped. 'placedesc.none' in the code should be 'u( placedesc.none )'. That is:

    @desc here=udefault( placedesc.[places( whichplace, %!, %# )], u( placedesc.none ))

    I apologize for the lapse of brainpower.

  • @Thenomain, thank you for posting how to work that on TR!

    I'm going to nudge the folks who inherited my big build there at some point to see if they want to convert the ZOMGhuge plook descs over to this format, since that's what I had originally hoped to do at the time.

  • @Thenomain: And that works beautifully. Thank you.

Log in to reply