Atlantis Client

  • Okay, so for rc5 the things I need to get in are:

    • Sparkle auto update
    • Convert font metric calculations from old style float to new style CGFloat (i.e. double)
    • Investigate why log closing only closes all logs
    • Investigate why global events might not work for some folks.
    • Investigate why Lemuria docking is broken (I.e. tearing off a spawn and having it vanish into the Land of Wind and Ghosts.)

    Anything else I'm missing? If not, I'll try to work on those this weekend some.

  • Pitcrew

    A correction to my previous post: I can't make events at all. Not at the Global, World or Character level. I crash every time. So spawn windows are out for me too.

  • @Goldfish said in Atlantis Client:

    A correction to my previous post: I can't make events at all. Not at the Global, World or Character level. I crash every time. So spawn windows are out for me too.

    Are you saying the Spawns tab is also broken? I was able to add spawns fine (though remove was broken in some cases; an issue I fixed in my current code tree and which will be in rc5).

    Or do you do all your spawn logic through the Events system?

  • Pitcrew

    @Sparks Events. The only way I know?

    So yeah, I had an Event Apocalypse.

  • @Goldfish - I'm actually glad to hear that; it'll let me track down the issue more easily. If it was affecting both events and the native interface for defining spawns (they feed through the same parser, however the specialized events created by the Spawns tab are less flexible but more easily created); since Spawns work fine, I can focus on the parts of the Event system that aren't in that flow. Narrows down where to look!

  • This probably speaks to how basic my MU client use is, because I've been on Mojave for awhile now and everything I care about is still working great. :) (I did notice the MUSH editor broke a couple of OS versions back, but I rarely used it so no biggie.)

    Thanks for keeping it alive though @Sparks!

  • @faraday — the old 32-bit version works fine on Mojave, and everything I used it for still worked for me too. But with the next OS release it would've stopped doing so, thus I really needed to get it ported to more up to date APIs anyway. Better to work the kinks out now rather than rushing when the next OS version hits.

    (I am considering when I get everything cleaned up just bundling all the dependencies into the main source tree and then turning my github repository public, make it open source.)

  • @Sparks said in Atlantis Client:

    @faraday — the old 32-bit version works fine on Mojave

    In the 32-bit version, I started losing lines in multi-line code. The lines were there, but would black out. I only used this for manually compressing Mux code, and I suspect it a problem with Mac and not Atlantis, but this was going on.

    Doesn’t happen on 64-bit version.

  • Created new world with [+] in Address Book, the system isn't letting me select it to set it up. Beta.


  • Pitcrew

    Similar issue on Created a new character under a world, couldn't select it to edit. However, closing and reopening the app made it possible for me to select and edit the character. (Also note, this version is still listed as Beta when you check the version info in the Atlantis client.)

  • Pitcrew

    Another bug, same version: tried to add a new hotkey. Got through the first prompt to set the hotkey itself, but when I selected the action to take -- in this case, directing focus to a specific spawn -- Atlantis crashed. Happened the next time I tried it, too.

Log in to reply